use strict;
my $str = '/***********************
***** SHOULD MATCH *****
***********************/
/* No quotes */
[class*=container] {}
/* Single quotes */
[class*=\'container\'] {}
/* Double quotes */
[class*="container"] {}
/* Multiple classes */
[class*="container"][class*="container-large"] {}
/**************************
***** SHOULDN\'T MATCH *****
**************************/
/* With = (exactly equal) */
[class="container"] {}
/* With ^= (begins with) */
[class^="container"] {}
/* With $= (ends with) */
[class$="container"] {}';
my $regex = qr/\[class\*=(?:"|')?(.*?)(?:"|')?\]/p;
my $subst = '.$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";