# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[class\*=(?:"|')?(.*?)(?:"|')?\]/.$1/g;t' <<< "/***********************
***** SHOULD MATCH *****
***********************/
/* No quotes */
[class*=container] {}
/* Single quotes */
[class*='container'] {}
/* Double quotes */
[class*=\"container\"] {}
/* Multiple classes */
[class*=\"container\"][class*=\"container-large\"] {}
/**************************
***** SHOULDN'T MATCH *****
**************************/
/* With = (exactly equal) */
[class=\"container\"] {}
/* With ^= (begins with) */
[class^=\"container\"] {}
/* With $= (ends with) */
[class$=\"container\"] {}"