package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[class\*=(?:"|')?(.*?)(?:"|')?\]`)
var str = `/***********************
***** SHOULD MATCH *****
***********************/
/* No quotes */
[class*=container] {}
/* Single quotes */
[class*='container'] {}
/* Double quotes */
[class*="container"] {}
/* Multiple classes */
[class*="container"][class*="container-large"] {}
/**************************
***** SHOULDN'T MATCH *****
**************************/
/* With = (exactly equal) */
[class="container"] {}
/* With ^= (begins with) */
[class^="container"] {}
/* With $= (ends with) */
[class$="container"] {}`
var substitution = ".$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}