# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(http|https)?:\/\/(www\.)?vimeo.com\/(?:channels\/(?:\w+\/)?|groups\/([^\/]*)\/videos\/|)(\d+)(?:|\/\?)"
test_str = ("Vimeo Regex\n\n"
"# plain ok\n"
"https://vimeo.com/62092214\n"
"http://vimeo.com/62092214\n"
"https://www.vimeo.com/62092214\n\n"
"# plain not ok\n"
"http://vimeo/62092214\n"
"http://vimeo.com/foo\n\n"
"# channels ok:\n"
"https://vimeo.com/channels/documentaryfilm/128373915\n\n"
"# channels not ok:\n"
"https://vimeo.com/channels/foo-barr/documentaryfilm/128373915\n\n"
"# groups ok:\n"
"https://vimeo.com/groups/musicvideo/videos/126199390\n\n"
"# groups not ok:\n"
"http://vimeo.com/groups/musicvideo/vid/126199390\n\n"
"# attributes ok:\n"
"https://vimeo.com/62092214?query=foo\n\n"
"# attributes not ok:\n"
"https://vimeo.com.omomom/62092214?query=foo")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.