using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http|https)?:\/\/(www\.)?vimeo.com\/(?:channels\/(?:\w+\/)?|groups\/([^\/]*)\/videos\/|)(\d+)(?:|\/\?)";
string input = @"Vimeo Regex
# plain ok
https://vimeo.com/62092214
http://vimeo.com/62092214
https://www.vimeo.com/62092214
# plain not ok
http://vimeo/62092214
http://vimeo.com/foo
# channels ok:
https://vimeo.com/channels/documentaryfilm/128373915
# channels not ok:
https://vimeo.com/channels/foo-barr/documentaryfilm/128373915
# groups ok:
https://vimeo.com/groups/musicvideo/videos/126199390
# groups not ok:
http://vimeo.com/groups/musicvideo/vid/126199390
# attributes ok:
https://vimeo.com/62092214?query=foo
# attributes not ok:
https://vimeo.com.omomom/62092214?query=foo";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}