package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(http|https)?:\/\/(www\.)?vimeo.com\/(?:channels\/(?:\w+\/)?|groups\/([^\/]*)\/videos\/|)(\d+)(?:|\/\?)`)
var str = `Vimeo Regex
# plain ok
https://vimeo.com/62092214
http://vimeo.com/62092214
https://www.vimeo.com/62092214
# plain not ok
http://vimeo/62092214
http://vimeo.com/foo
# channels ok:
https://vimeo.com/channels/documentaryfilm/128373915
# channels not ok:
https://vimeo.com/channels/foo-barr/documentaryfilm/128373915
# groups ok:
https://vimeo.com/groups/musicvideo/videos/126199390
# groups not ok:
http://vimeo.com/groups/musicvideo/vid/126199390
# attributes ok:
https://vimeo.com/62092214?query=foo
# attributes not ok:
https://vimeo.com.omomom/62092214?query=foo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}