use strict;
my $str = 'Vimeo Regex
# plain ok
https://vimeo.com/62092214
http://vimeo.com/62092214
https://www.vimeo.com/62092214
# plain not ok
http://vimeo/62092214
http://vimeo.com/foo
# channels ok:
https://vimeo.com/channels/documentaryfilm/128373915
# channels not ok:
https://vimeo.com/channels/foo-barr/documentaryfilm/128373915
# groups ok:
https://vimeo.com/groups/musicvideo/videos/126199390
# groups not ok:
http://vimeo.com/groups/musicvideo/vid/126199390
# attributes ok:
https://vimeo.com/62092214?query=foo
# attributes not ok:
https://vimeo.com.omomom/62092214?query=foo';
my $regex = qr/(http|https)?:\/\/(www\.)?vimeo.com\/(?:channels\/(?:\w+\/)?|groups\/([^\/]*)\/videos\/|)(\d+)(?:|\/\?)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}