import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http|https)?:\\/\\/(www\\.)?vimeo.com\\/(?:channels\\/(?:\\w+\\/)?|groups\\/([^\\/]*)\\/videos\\/|)(\\d+)(?:|\\/\\?)";
final String string = "Vimeo Regex\n\n"
+ "# plain ok\n"
+ "https://vimeo.com/62092214\n"
+ "http://vimeo.com/62092214\n"
+ "https://www.vimeo.com/62092214\n\n"
+ "# plain not ok\n"
+ "http://vimeo/62092214\n"
+ "http://vimeo.com/foo\n\n"
+ "# channels ok:\n"
+ "https://vimeo.com/channels/documentaryfilm/128373915\n\n"
+ "# channels not ok:\n"
+ "https://vimeo.com/channels/foo-barr/documentaryfilm/128373915\n\n"
+ "# groups ok:\n"
+ "https://vimeo.com/groups/musicvideo/videos/126199390\n\n"
+ "# groups not ok:\n"
+ "http://vimeo.com/groups/musicvideo/vid/126199390\n\n"
+ "# attributes ok:\n"
+ "https://vimeo.com/62092214?query=foo\n\n"
+ "# attributes not ok:\n"
+ "https://vimeo.com.omomom/62092214?query=foo";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}