const regex = new RegExp('(http|https)?:\\/\\/(www\\.)?vimeo.com\\/(?:channels\\/(?:\\w+\\/)?|groups\\/([^\\/]*)\\/videos\\/|)(\\d+)(?:|\\/\\?)', 'g')
const str = `Vimeo Regex
# plain ok
https://vimeo.com/62092214
http://vimeo.com/62092214
https://www.vimeo.com/62092214
# plain not ok
http://vimeo/62092214
http://vimeo.com/foo
# channels ok:
https://vimeo.com/channels/documentaryfilm/128373915
# channels not ok:
https://vimeo.com/channels/foo-barr/documentaryfilm/128373915
# groups ok:
https://vimeo.com/groups/musicvideo/videos/126199390
# groups not ok:
http://vimeo.com/groups/musicvideo/vid/126199390
# attributes ok:
https://vimeo.com/62092214?query=foo
# attributes not ok:
https://vimeo.com.omomom/62092214?query=foo`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}