import Foundation
let pattern = #"^(?:https?:\/\/)?(?:www\.)?t(?:elegram)?\.(?:org|me|dog)\/(?:c\/(?<chat_id>\d+)|(?<username>[a-zA-Z](?:_(?!_)|[a-zA-Z0-9]){2,30}[a-zA-Z0-9]))(?:\/(?<thread_id>\d+))?(?:\/(?<message_id>\d+))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://t.me/123456789/4321
https://t.me/c/username/4321
https://t.me/c/username/1/1558
https://t.me/c/123456789
https://t.me/username
https://t.me/username_/1/1558
https://t.me/_username/1/1558
https://t.me/auto/1/1558
https://t.me/username/1/1558
https://t.me/c/123456789/2/3342
https://t.me/c/123456789/4321
https://t.me/c123456789/4321
http://t.me/username/4321
t.me/c/123456789/4321
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)