using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:https?:\/\/)?(?:www\.)?t(?:elegram)?\.(?:org|me|dog)\/(?:c\/(?<chat_id>\d+)|(?<username>[a-zA-Z](?:_(?!_)|[a-zA-Z0-9]){2,30}[a-zA-Z0-9]))(?:\/(?<thread_id>\d+))?(?:\/(?<message_id>\d+))";
string input = @"https://t.me/123456789/4321
https://t.me/c/username/4321
https://t.me/c/username/1/1558
https://t.me/c/123456789
https://t.me/username
https://t.me/username_/1/1558
https://t.me/_username/1/1558
https://t.me/auto/1/1558
https://t.me/username/1/1558
https://t.me/c/123456789/2/3342
https://t.me/c/123456789/4321
https://t.me/c123456789/4321
http://t.me/username/4321
t.me/c/123456789/4321";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}