import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:\\/\\/)?(?:www\\.)?t(?:elegram)?\\.(?:org|me|dog)\\/(?:c\\/(?<chat_id>\\d+)|(?<username>[a-zA-Z](?:_(?!_)|[a-zA-Z0-9]){2,30}[a-zA-Z0-9]))(?:\\/(?<thread_id>\\d+))?(?:\\/(?<message_id>\\d+))";
final String string = "https://t.me/123456789/4321\n"
+ "https://t.me/c/username/4321\n"
+ "https://t.me/c/username/1/1558\n"
+ "https://t.me/c/123456789\n"
+ "https://t.me/username\n"
+ "https://t.me/username_/1/1558\n"
+ "https://t.me/_username/1/1558\n\n"
+ "https://t.me/auto/1/1558\n"
+ "https://t.me/username/1/1558\n"
+ "https://t.me/c/123456789/2/3342\n"
+ "https://t.me/c/123456789/4321\n"
+ "https://t.me/c123456789/4321\n"
+ "http://t.me/username/4321\n"
+ "t.me/c/123456789/4321";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}