$re = '/^(?:https?:\/\/)?(?:www\.)?t(?:elegram)?\.(?:org|me|dog)\/(?:c\/(?<chat_id>\d+)|(?<username>[a-zA-Z](?:_(?!_)|[a-zA-Z0-9]){2,30}[a-zA-Z0-9]))(?:\/(?<thread_id>\d+))?(?:\/(?<message_id>\d+))/m';
$str = 'https://t.me/123456789/4321
https://t.me/c/username/4321
https://t.me/c/username/1/1558
https://t.me/c/123456789
https://t.me/username
https://t.me/username_/1/1558
https://t.me/_username/1/1558
https://t.me/auto/1/1558
https://t.me/username/1/1558
https://t.me/c/123456789/2/3342
https://t.me/c/123456789/4321
https://t.me/c123456789/4321
http://t.me/username/4321
t.me/c/123456789/4321';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);