# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:https?:\/\/)?(?:www\.)?t(?:elegram)?\.(?:org|me|dog)\/(?:c\/(?<chat_id>\d+)|(?<username>[a-zA-Z](?:_(?!_)|[a-zA-Z0-9]){2,30}[a-zA-Z0-9]))(?:\/(?<thread_id>\d+))?(?:\/(?<message_id>\d+))"
test_str = ("https://t.me/123456789/4321\n"
"https://t.me/c/username/4321\n"
"https://t.me/c/username/1/1558\n"
"https://t.me/c/123456789\n"
"https://t.me/username\n"
"https://t.me/username_/1/1558\n"
"https://t.me/_username/1/1558\n\n"
"https://t.me/auto/1/1558\n"
"https://t.me/username/1/1558\n"
"https://t.me/c/123456789/2/3342\n"
"https://t.me/c/123456789/4321\n"
"https://t.me/c123456789/4321\n"
"http://t.me/username/4321\n"
"t.me/c/123456789/4321")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.