#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:https?:\/\/)?(?:www\.)?t(?:elegram)?\.(?:org|me|dog)\/(?:c\/(?<chat_id>\d+)|(?<username>[a-zA-Z](?:_(?!_)|[a-zA-Z0-9]){2,30}[a-zA-Z0-9]))(?:\/(?<thread_id>\d+))?(?:\/(?<message_id>\d+))"
Local $sString = "https://t.me/123456789/4321" & @CRLF & _
"https://t.me/c/username/4321" & @CRLF & _
"https://t.me/c/username/1/1558" & @CRLF & _
"https://t.me/c/123456789" & @CRLF & _
"https://t.me/username" & @CRLF & _
"https://t.me/username_/1/1558" & @CRLF & _
"https://t.me/_username/1/1558" & @CRLF & _
"" & @CRLF & _
"https://t.me/auto/1/1558" & @CRLF & _
"https://t.me/username/1/1558" & @CRLF & _
"https://t.me/c/123456789/2/3342" & @CRLF & _
"https://t.me/c/123456789/4321" & @CRLF & _
"https://t.me/c123456789/4321" & @CRLF & _
"http://t.me/username/4321" & @CRLF & _
"t.me/c/123456789/4321"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")