// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+)").unwrap();
let string = "33081001354
33081001354
230860686
230860686
230860686
173590050
1186018759
91614361
211828522
91082248
91082248";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}