import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)";
final String string = "33081001354\n"
+ "33081001354\n"
+ "230860686\n"
+ "230860686\n"
+ "230860686\n"
+ "173590050\n"
+ "1186018759\n"
+ "91614361\n"
+ "211828522\n"
+ "91082248\n"
+ "91082248";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}