re = /(\d+)/m
str = '33081001354
33081001354
230860686
230860686
230860686
173590050
1186018759
91614361
211828522
91082248
91082248'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end