package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)`)
var str = `33081001354
33081001354
230860686
230860686
230860686
173590050
1186018759
91614361
211828522
91082248
91082248`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}