#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+)"
Local $sString = "33081001354" & @CRLF & _
"33081001354" & @CRLF & _
"230860686" & @CRLF & _
"230860686" & @CRLF & _
"230860686" & @CRLF & _
"173590050" & @CRLF & _
"1186018759" & @CRLF & _
"91614361" & @CRLF & _
"211828522" & @CRLF & _
"91082248" & @CRLF & _
"91082248"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")