// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([0-9]{2,3}) {1,}([0-9]{4})-([a-zA-Z])").unwrap();
let string = "123 4567-A
1234567-A
123 4567A
1234567A";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}