const regex = /([0-9]{2,3}) {1,}([0-9]{4})-([a-zA-Z])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]{2,3}) {1,}([0-9]{4})-([a-zA-Z])', 'g')
const str = `123 4567-A
1234567-A
123 4567A
1234567A`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}