re = /([0-9]{2,3}) {1,}([0-9]{4})-([a-zA-Z])/
str = '123 4567-A
1234567-A
123 4567A
1234567A'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end