$re = '/([0-9]{2,3}) {1,}([0-9]{4})-([a-zA-Z])/';
$str = '123 4567-A
1234567-A
123 4567A
1234567A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);