package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9]{2,3}) {1,}([0-9]{4})-([a-zA-Z])`)
var str = `123 4567-A
1234567-A
123 4567A
1234567A`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}