using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]{2,3}) {1,}([0-9]{4})-([a-zA-Z])";
string input = @"123 4567-A
1234567-A
123 4567A
1234567A";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}