import Foundation
let pattern = #"(?<=\s)(?<start>%%)?%dMODIFIER_PROPERTY_(\w+)%(?(start)|%%)(?=[^%]|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"DOTA_Tooltip_modifier_viper_poison_attack_slow_Description" "Velocidad de movimiento reducida un %dMODIFIER_PROPERTY_MOVESPEED_BONUS_PERCENTAGE%%%, resistencia mágica reducida un %dMODIFIER_PROPERTY_MAGICAL_RESISTANCE_BONUS%%%. Recibiendo daño a lo largo del tiempo."
%%%dMODIFIER_PROPERTY_SOMETHING%
%%dMODIFIER_PROPERTY_SOMETHING%
%%%%dMODIFIER_PROPERTY_SOMETHING%
%%%dMODIFIER_PROPERTY_SOMETHING%%
%%%dMODIFIER_PROPERTY_SOMETHING%%%
%dMODIFIER_PROPERTY_SOMETHING%
%dMODIFIER_PROPERTY_SOMETHING%%
%dMODIFIER_PROPERTY_SOMETHING%%%
%dMODIFIER_PROPERTY_SOMETHING%%%%
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)