const regex = /(?<=\s)(?<start>%%)?%dMODIFIER_PROPERTY_(\w+)%(?(start)|%%)(?=[^%]|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\s)(?<start>%%)?%dMODIFIER_PROPERTY_(\\w+)%(?(start)|%%)(?=[^%]|$)', 'gm')
const str = `"DOTA_Tooltip_modifier_viper_poison_attack_slow_Description" "Velocidad de movimiento reducida un %dMODIFIER_PROPERTY_MOVESPEED_BONUS_PERCENTAGE%%%, resistencia mágica reducida un %dMODIFIER_PROPERTY_MAGICAL_RESISTANCE_BONUS%%%. Recibiendo daño a lo largo del tiempo."
%%%dMODIFIER_PROPERTY_SOMETHING%
%%dMODIFIER_PROPERTY_SOMETHING%
%%%%dMODIFIER_PROPERTY_SOMETHING%
%%%dMODIFIER_PROPERTY_SOMETHING%%
%%%dMODIFIER_PROPERTY_SOMETHING%%%
%dMODIFIER_PROPERTY_SOMETHING%
%dMODIFIER_PROPERTY_SOMETHING%%
%dMODIFIER_PROPERTY_SOMETHING%%%
%dMODIFIER_PROPERTY_SOMETHING%%%%`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}