re = /(?<=\s)(?<start>%%)?%dMODIFIER_PROPERTY_(\w+)%(?(start)|%%)(?=[^%]|$)/m
str = '"DOTA_Tooltip_modifier_viper_poison_attack_slow_Description" "Velocidad de movimiento reducida un %dMODIFIER_PROPERTY_MOVESPEED_BONUS_PERCENTAGE%%%, resistencia mágica reducida un %dMODIFIER_PROPERTY_MAGICAL_RESISTANCE_BONUS%%%. Recibiendo daño a lo largo del tiempo."
%%%dMODIFIER_PROPERTY_SOMETHING%
%%dMODIFIER_PROPERTY_SOMETHING%
%%%%dMODIFIER_PROPERTY_SOMETHING%
%%%dMODIFIER_PROPERTY_SOMETHING%%
%%%dMODIFIER_PROPERTY_SOMETHING%%%
%dMODIFIER_PROPERTY_SOMETHING%
%dMODIFIER_PROPERTY_SOMETHING%%
%dMODIFIER_PROPERTY_SOMETHING%%%
%dMODIFIER_PROPERTY_SOMETHING%%%%'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end