using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\s)(?<start>%%)?%dMODIFIER_PROPERTY_(\w+)%(?(start)|%%)(?=[^%]|$)";
string input = @"""DOTA_Tooltip_modifier_viper_poison_attack_slow_Description"" ""Velocidad de movimiento reducida un %dMODIFIER_PROPERTY_MOVESPEED_BONUS_PERCENTAGE%%%, resistencia mágica reducida un %dMODIFIER_PROPERTY_MAGICAL_RESISTANCE_BONUS%%%. Recibiendo daño a lo largo del tiempo.""
%%%dMODIFIER_PROPERTY_SOMETHING%
%%dMODIFIER_PROPERTY_SOMETHING%
%%%%dMODIFIER_PROPERTY_SOMETHING%
%%%dMODIFIER_PROPERTY_SOMETHING%%
%%%dMODIFIER_PROPERTY_SOMETHING%%%
%dMODIFIER_PROPERTY_SOMETHING%
%dMODIFIER_PROPERTY_SOMETHING%%
%dMODIFIER_PROPERTY_SOMETHING%%%
%dMODIFIER_PROPERTY_SOMETHING%%%%";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}