use strict;
my $str = '"DOTA_Tooltip_modifier_viper_poison_attack_slow_Description" "Velocidad de movimiento reducida un %dMODIFIER_PROPERTY_MOVESPEED_BONUS_PERCENTAGE%%%, resistencia mágica reducida un %dMODIFIER_PROPERTY_MAGICAL_RESISTANCE_BONUS%%%. Recibiendo daño a lo largo del tiempo."
%%%dMODIFIER_PROPERTY_SOMETHING%
%%dMODIFIER_PROPERTY_SOMETHING%
%%%%dMODIFIER_PROPERTY_SOMETHING%
%%%dMODIFIER_PROPERTY_SOMETHING%%
%%%dMODIFIER_PROPERTY_SOMETHING%%%
%dMODIFIER_PROPERTY_SOMETHING%
%dMODIFIER_PROPERTY_SOMETHING%%
%dMODIFIER_PROPERTY_SOMETHING%%%
%dMODIFIER_PROPERTY_SOMETHING%%%%';
my $regex = qr/(?<=\s)(?<start>%%)?%dMODIFIER_PROPERTY_(\w+)%(?(start)|%%)(?=[^%]|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}