import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\s)(?<start>%%)?%dMODIFIER_PROPERTY_(\\w+)%(?(start)|%%)(?=[^%]|$)";
final String string = "\"DOTA_Tooltip_modifier_viper_poison_attack_slow_Description\" \"Velocidad de movimiento reducida un %dMODIFIER_PROPERTY_MOVESPEED_BONUS_PERCENTAGE%%%, resistencia mágica reducida un %dMODIFIER_PROPERTY_MAGICAL_RESISTANCE_BONUS%%%. Recibiendo daño a lo largo del tiempo.\"\n"
+ "%%%dMODIFIER_PROPERTY_SOMETHING%\n"
+ "%%dMODIFIER_PROPERTY_SOMETHING%\n"
+ "%%%%dMODIFIER_PROPERTY_SOMETHING%\n"
+ "%%%dMODIFIER_PROPERTY_SOMETHING%%\n"
+ "%%%dMODIFIER_PROPERTY_SOMETHING%%%\n"
+ "%dMODIFIER_PROPERTY_SOMETHING%\n"
+ "%dMODIFIER_PROPERTY_SOMETHING%%\n"
+ "%dMODIFIER_PROPERTY_SOMETHING%%%\n"
+ "%dMODIFIER_PROPERTY_SOMETHING%%%%";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}