re = /\.(psd|ai|jpg|jpeg|gif)/mi
str = 'uis 2,5L+0,5L GRATIS.jpeg
xyla_01.psd
xtend-climb-logo.ai
X38162 Diamond BLADE.psd
X065N - 5414045990656.jpg
x-run-logo.ai
xtend-climb-logo.gif
X38162 Diamond BLADE.psd
X065N - 5414045990656.jpg
x-run-logo.ai'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end