using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(psd|ai|jpg|jpeg|gif)";
string input = @"uis 2,5L+0,5L GRATIS.jpeg
xyla_01.psd
xtend-climb-logo.ai
X38162 Diamond BLADE.psd
X065N - 5414045990656.jpg
x-run-logo.ai
xtend-climb-logo.gif
X38162 Diamond BLADE.psd
X065N - 5414045990656.jpg
x-run-logo.ai";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}