import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.(psd|ai|jpg|jpeg|gif)";
final String string = "uis 2,5L+0,5L GRATIS.jpeg\n"
+ "xyla_01.psd\n"
+ "xtend-climb-logo.ai\n"
+ "X38162 Diamond BLADE.psd\n"
+ "X065N - 5414045990656.jpg\n"
+ "x-run-logo.ai\n"
+ "xtend-climb-logo.gif\n"
+ "X38162 Diamond BLADE.psd\n"
+ "X065N - 5414045990656.jpg\n"
+ "x-run-logo.ai";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}