const regex = /\.(psd|ai|jpg|jpeg|gif)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(psd|ai|jpg|jpeg|gif)', 'gmi')
const str = `uis 2,5L+0,5L GRATIS.jpeg
xyla_01.psd
xtend-climb-logo.ai
X38162 Diamond BLADE.psd
X065N - 5414045990656.jpg
x-run-logo.ai
xtend-climb-logo.gif
X38162 Diamond BLADE.psd
X065N - 5414045990656.jpg
x-run-logo.ai`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}