#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\.(psd|ai|jpg|jpeg|gif)"
Local $sString = "uis 2,5L+0,5L GRATIS.jpeg" & @CRLF & _
"xyla_01.psd" & @CRLF & _
"xtend-climb-logo.ai" & @CRLF & _
"X38162 Diamond BLADE.psd" & @CRLF & _
"X065N - 5414045990656.jpg" & @CRLF & _
"x-run-logo.ai" & @CRLF & _
"xtend-climb-logo.gif" & @CRLF & _
"X38162 Diamond BLADE.psd" & @CRLF & _
"X065N - 5414045990656.jpg" & @CRLF & _
"x-run-logo.ai"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")