use strict;
my $str = 'uis 2,5L+0,5L GRATIS.jpeg
xyla_01.psd
xtend-climb-logo.ai
X38162 Diamond BLADE.psd
X065N - 5414045990656.jpg
x-run-logo.ai
xtend-climb-logo.gif
X38162 Diamond BLADE.psd
X065N - 5414045990656.jpg
x-run-logo.ai';
my $regex = qr/\.(psd|ai|jpg|jpeg|gif)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}