re = /^BusinessServices\/(.*)\/(.*)\/Interface\/(((.*)(_EMSReceiver|_PushFilesPoller))|(JobScheduler|LoadSpainRoutingTableData|PurgeDirectories))\.process/m
str = 'BusinessServices/V001/Common/Interface/JMSFileSender.process
BusinessServices/V001/Common/Interface/JobScheduler.process
BusinessServices/V001/Common/Interface/LoadSpainRoutingTableData.process
BusinessServices/V001/Common/Interface/Logys_Impl.process
BusinessServices/V001/Common/Interface/PurgeDirectories.process
BusinessServices/V001/D365/Interface/D365_EMSReceiver.process
BusinessServices/V001/SOURCE/Interface/SOURCE_PushFilesPoller.process
BusinessServices/V001/TARGET/Interface/TARGET_EMSReceiver.process'
subst = 'Service=$1-$2, Operation=$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result