# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^BusinessServices\\/(.*)\\/(.*)\\/Interface\\/(((.*)(_EMSReceiver|_PushFilesPoller))|(JobScheduler|LoadSpainRoutingTableData|PurgeDirectories))\.process/Service=$1-$2, Operation=$3/gm;t' <<< "BusinessServices/V001/Common/Interface/JMSFileSender.process
BusinessServices/V001/Common/Interface/JobScheduler.process
BusinessServices/V001/Common/Interface/LoadSpainRoutingTableData.process
BusinessServices/V001/Common/Interface/Logys_Impl.process
BusinessServices/V001/Common/Interface/PurgeDirectories.process
BusinessServices/V001/D365/Interface/D365_EMSReceiver.process
BusinessServices/V001/SOURCE/Interface/SOURCE_PushFilesPoller.process
BusinessServices/V001/TARGET/Interface/TARGET_EMSReceiver.process"