using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^BusinessServices\/(.*)\/(.*)\/Interface\/(((.*)(_EMSReceiver|_PushFilesPoller))|(JobScheduler|LoadSpainRoutingTableData|PurgeDirectories))\.process";
string substitution = @"Service=$1-$2, Operation=$3";
string input = @"BusinessServices/V001/Common/Interface/JMSFileSender.process
BusinessServices/V001/Common/Interface/JobScheduler.process
BusinessServices/V001/Common/Interface/LoadSpainRoutingTableData.process
BusinessServices/V001/Common/Interface/Logys_Impl.process
BusinessServices/V001/Common/Interface/PurgeDirectories.process
BusinessServices/V001/D365/Interface/D365_EMSReceiver.process
BusinessServices/V001/SOURCE/Interface/SOURCE_PushFilesPoller.process
BusinessServices/V001/TARGET/Interface/TARGET_EMSReceiver.process";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}