const regex = /^BusinessServices\/(.*)\/(.*)\/Interface\/(((.*)(_EMSReceiver|_PushFilesPoller))|(JobScheduler|LoadSpainRoutingTableData|PurgeDirectories))\.process/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^BusinessServices\\\/(.*)\\\/(.*)\\\/Interface\\\/(((.*)(_EMSReceiver|_PushFilesPoller))|(JobScheduler|LoadSpainRoutingTableData|PurgeDirectories))\\.process', 'gm')
const str = `BusinessServices/V001/Common/Interface/JMSFileSender.process
BusinessServices/V001/Common/Interface/JobScheduler.process
BusinessServices/V001/Common/Interface/LoadSpainRoutingTableData.process
BusinessServices/V001/Common/Interface/Logys_Impl.process
BusinessServices/V001/Common/Interface/PurgeDirectories.process
BusinessServices/V001/D365/Interface/D365_EMSReceiver.process
BusinessServices/V001/SOURCE/Interface/SOURCE_PushFilesPoller.process
BusinessServices/V001/TARGET/Interface/TARGET_EMSReceiver.process`;
const subst = `Service=$1-$2, Operation=$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);