# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^BusinessServices\/(.*)\/(.*)\/Interface\/(((.*)(_EMSReceiver|_PushFilesPoller))|(JobScheduler|LoadSpainRoutingTableData|PurgeDirectories))\.process"
test_str = ("BusinessServices/V001/Common/Interface/JMSFileSender.process\n"
"BusinessServices/V001/Common/Interface/JobScheduler.process\n"
"BusinessServices/V001/Common/Interface/LoadSpainRoutingTableData.process\n"
"BusinessServices/V001/Common/Interface/Logys_Impl.process\n"
"BusinessServices/V001/Common/Interface/PurgeDirectories.process\n"
"BusinessServices/V001/D365/Interface/D365_EMSReceiver.process\n"
"BusinessServices/V001/SOURCE/Interface/SOURCE_PushFilesPoller.process\n"
"BusinessServices/V001/TARGET/Interface/TARGET_EMSReceiver.process")
subst = "Service=$1-$2, Operation=$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.