import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^BusinessServices\\/(.*)\\/(.*)\\/Interface\\/(((.*)(_EMSReceiver|_PushFilesPoller))|(JobScheduler|LoadSpainRoutingTableData|PurgeDirectories))\\.process";
final String string = "BusinessServices/V001/Common/Interface/JMSFileSender.process\n"
+ "BusinessServices/V001/Common/Interface/JobScheduler.process\n"
+ "BusinessServices/V001/Common/Interface/LoadSpainRoutingTableData.process\n"
+ "BusinessServices/V001/Common/Interface/Logys_Impl.process\n"
+ "BusinessServices/V001/Common/Interface/PurgeDirectories.process\n"
+ "BusinessServices/V001/D365/Interface/D365_EMSReceiver.process\n"
+ "BusinessServices/V001/SOURCE/Interface/SOURCE_PushFilesPoller.process\n"
+ "BusinessServices/V001/TARGET/Interface/TARGET_EMSReceiver.process";
final String subst = "Service=$1-$2, Operation=$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}