// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^([A-Z][a-z-]+),? +([A-Z])[^\n]*").unwrap();
let string = "Grundy Ronald
Domsky Alan
Amator Gary L & Kathleen N
Worden Scott Allen
Rodriguez Howard W
NEHME ALLEN
RODRIGUEZ CHARLES G
VERGARA WILLIAM F J
EVELYN J
GLICK, JACOB L.
Taylor-garcia Dottielou";
let substitution = "$2-$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}