package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^([A-Z][a-z-]+),? +([A-Z])[^\n]*`)
var str = `Grundy Ronald
Domsky Alan
Amator Gary L & Kathleen N
Worden Scott Allen
Rodriguez Howard W
NEHME ALLEN
RODRIGUEZ CHARLES G
VERGARA WILLIAM F J
EVELYN J
GLICK, JACOB L.
Taylor-garcia Dottielou`
var substitution = "$2-$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}