using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-Z][a-z-]+),? +([A-Z])[^\n]*";
string substitution = @"$2-$1";
string input = @"Grundy Ronald
Domsky Alan
Amator Gary L & Kathleen N
Worden Scott Allen
Rodriguez Howard W
NEHME ALLEN
RODRIGUEZ CHARLES G
VERGARA WILLIAM F J
EVELYN J
GLICK, JACOB L.
Taylor-garcia Dottielou";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}