import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Z][a-z-]+),? +([A-Z])[^\\n]*";
final String string = "Grundy Ronald\n"
+ "Domsky Alan\n"
+ "Amator Gary L & Kathleen N\n"
+ "Worden Scott Allen\n"
+ "Rodriguez Howard W\n"
+ "NEHME ALLEN \n"
+ "RODRIGUEZ CHARLES G\n"
+ "VERGARA WILLIAM F J\n"
+ "EVELYN J\n"
+ "GLICK, JACOB L. \n"
+ "Taylor-garcia Dottielou";
final String subst = "$2-$1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}