re = /^([A-Z][a-z-]+),? +([A-Z])[^\n]*/im
str = 'Grundy Ronald
Domsky Alan
Amator Gary L & Kathleen N
Worden Scott Allen
Rodriguez Howard W
NEHME ALLEN
RODRIGUEZ CHARLES G
VERGARA WILLIAM F J
EVELYN J
GLICK, JACOB L.
Taylor-garcia Dottielou'
subst = '$2-$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result