import Foundation
let pattern = #"[\[\(<](?:(?:yes|YES)[\/,](?:no|NO)|(?:no|NO)[\/,](?:yes|YES))(?:[\/,].*?)?[>\)\]]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
This operation bla bla bla...
Confirm this command? [YES,no] - N as default
Confirm this command? [yes,NO] - N as default
Confirm this command? [yes,no] - N as default
Confirm this command? [YES,no,cancel] - N as default
Confirm this command? [yes,NO,cancel] - N as default
Confirm this command? [yes,no,CANCEL] - N as default
Confirm this command? [YES/no] - N as default
Confirm this command? [yes/NO] - N as default
Confirm this command? [yes/no] - N as default
Confirm this command? [YES/no/cancel] - N as default
Confirm this command? [yes/NO/cancel] - N as default
Confirm this command? [yes/no/CANCEL] - N as default
Confirm this command? [no,YES] - Y as default
Confirm this command? [NO,yes] - Y as default
Confirm this command? [no,yes] - Y as default
Confirm this command? [no/YES] - Y as default
Confirm this command? [NO/yes] - Y as default
Confirm this command? [no/yes] - Y as default
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)